Thursday, March 27, 2008

Where is the activerecord-informix-adapter gem?

I was waiting for the next release of Ruby on Rails to say this, but it's taking more time than I expected.

Rails/Informix was already imported in the Ruby on Rails SVN repository back on October 14th, 2007, but the activerecord-informix-adapter gem was not available as expected when Ruby on Rails 2.0 was released.

Well, Jeremy Kemper was so kind to tell me on December 27th, 2007, that the activerecord-informix-adapter gem will be available in the next release of Ruby on Rails. It was not available before because it was not connected to the build system. It was already fixed.

Meanwhile, you can take advantage of the Informix adapter now, installing it by hand, following the installation instructions for Rails 1.x, except for the part of editing a file. Just copy the file informix_adapter.rb to the location mentioned, and enjoy!

No comments: